EcoStruxure IT mobile app loading issues on Android 14 devices with version 4.2.5b3189

Incident Report for EcoStruxure IT

Resolved

The new app version 4.2.6b3193 is available on Google PlayStores. There might be delays in getting the latest version in some regions.
We regret the inconvenience caused.
Posted Mar 08, 2024 - 14:01 UTC

Monitoring

We are monitoring the new version we released. The new version should hit the Google play stores in couple of hours
Posted Mar 08, 2024 - 13:23 UTC

Investigating

We are currently investigating the issue.
Posted Mar 08, 2024 - 13:20 UTC
This incident affected: EcoStruxure IT Mobile.