EcoStruxure IT Service Interruption
Incident Report for EcoStruxure IT
Postmortem

EcoStruxure IT Expert, EcoStruxure IT Advisor (hosted), and Asset Advisor were unavailable due to the outage of a third-party component called Auth0 that is critical to operation. Auth0 provides authentication services for our EcoStruxure IT platform and ticketing system, and had global service-wide downtime lasting approximately 3 hours today. 

Our platform engineering team was fully engaged throughout the incident, but was unable to remediate until 3rd party restoration by Auth0 itself. Throughout, we remained urgently committed to restoration of EcoStruxure IT services.

We sincerely apologize for this incident. With 24x7/365 DevOps coverage of our platform, continuous availability of the EcoStruxure IT platform is our top priority. You are a valued customer, and we will learn from this event to ensure it’s not repeated in the future. Please don’t hesitate to reach out if you have any further questions or concerns.

Posted Apr 21, 2021 - 06:11 UTC

Resolved
The issue has been resolved.
Posted Apr 20, 2021 - 23:53 UTC
Monitoring
The external service provider has found a fix and seeing improvements on their service.
Posted Apr 20, 2021 - 21:20 UTC
Update
Related to login issues we are seeing errors with push notifications not being able to be sent.
Posted Apr 20, 2021 - 17:03 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 20, 2021 - 15:51 UTC
Identified
We have identified an issue with an external service provider, that prevent you from login into EcoStruxure IT.
Both app and web UI is affected.
Posted Apr 20, 2021 - 15:51 UTC
This incident affected: EcoStruxure IT Expert and EcoStruxure IT Mobile.