Problem with receiving support emails
Incident Report for EcoStruxure IT
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 20, 2019 - 06:42 UTC
Identified
We have identified an issue with a third party provider and are working with them to resolve the issue.
Posted 4 months ago. Jun 14, 2019 - 09:45 UTC
Investigating
We are currently experiencing an intermittent issue with receiving emails​ send to support@ecostruxureit.com

If you send a support email and do not get a reply that we have received your ticket, please go to https://helpcenter.ecostruxureit.com and click "Submit a ticket" in the top right corner.
Posted 4 months ago. Jun 14, 2019 - 08:00 UTC