EcoStruxure IT Support is unavailable

Incident Report for EcoStruxure IT

Resolved

This incident has been resolved.
Posted May 09, 2025 - 07:54 UTC

Investigating

We are experiencing issues with that affect the EcoStruxure IT support ticketing system. We are working on a solution. In the interim, please email support@ecostruxureit.com.
Posted May 08, 2025 - 17:27 UTC
This incident affected: EcoStruxure IT frontpage and help center.