Measurement Processing Delays
Incident Report for EcoStruxure IT
Resolved
This incident has been resolved.
Posted Mar 08, 2024 - 23:40 UTC
Investigating
We have identified an issue with our data processing infrastructure and are working on a fix.
The issue is causing measurements to be delayed for some customers.

No data has been lost.
Posted Mar 08, 2024 - 22:08 UTC
This incident affected: EcoStruxure IT Expert and EcoStruxure IT Mobile.