EcoStruxure IT Mobile app(ANDROID only) fails loading for some of the non-English languages

Incident Report for EcoStruxure IT

Resolved

This incident has been resolved and a new version of the Android app is available on the Google play store.
Posted Oct 11, 2021 - 19:35 UTC

Investigating

We are currently working on a fix.
Posted Oct 11, 2021 - 13:33 UTC
This incident affected: EcoStruxure IT Mobile.