Data Processing Delays
Incident Report for EcoStruxure IT
Resolved
This incident has been resolved.
Posted 5 months ago. Jan 21, 2019 - 12:21 UTC
Investigating
Our data processing infrastructure is running behind which is causing inaccuracies in the data shown.
No data has been lost and the system should catch up shortly.
Posted 5 months ago. Jan 21, 2019 - 11:40 UTC