Data Processing Delays
Incident Report for EcoStruxure IT
Resolved
Data processing is back to normal
Posted 3 months ago. Jan 22, 2019 - 23:30 UTC
Investigating
Our data processing infrastructure is running behind which is causing inaccuracies in the data shown.
No data has been lost and the system should catch up shortly.
Posted 3 months ago. Jan 22, 2019 - 22:19 UTC